summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 21 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 01ed1b3cd31..d54f7e555f6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1434,6 +1434,27 @@ if test "x$enable_gallium_nouveau" = xyes; then
fi
dnl
+dnl Gallium G3DVL configuration
+dnl
+AC_ARG_ENABLE([gallium-g3dvl],
+ [AS_HELP_STRING([--enable-gallium-g3dvl],
+ [build gallium g3dvl @<:@default=disabled@:>@])],
+ [enable_gallium_g3dvl="$enableval"],
+ [enable_gallium_g3dvl=no])
+if test "x$enable_gallium_g3dvl" = xyes; then
+ vl_winsys_dirs=""
+ for dir in $GALLIUM_WINSYS_DIRS; do
+ vl_winsys_dirs="$vl_winsys_dirs g3dvl/$dir"
+ done
+ # Hack, g3dvl dri state tracker is in winsys/g3dvl/dri
+ # and needs to be built before the drm bits
+ if test "$mesa_driver" = dri; then
+ vl_winsys_dirs="g3dvl/dri $vl_winsys_dirs"
+ fi
+ GALLIUM_WINSYS_DIRS="$GALLIUM_WINSYS_DIRS $vl_winsys_dirs"
+fi
+
+dnl
dnl Gallium swrast configuration
dnl
AC_ARG_ENABLE([gallium-swrast],