summaryrefslogtreecommitdiffstats
path: root/src/vulkan/wsi/meson.build
diff options
context:
space:
mode:
authorDaniel Stone <[email protected]>2018-02-09 15:43:30 -0800
committerDaniel Stone <[email protected]>2018-02-21 22:37:10 +0000
commitbfa22266cd4d268e52d2535b41ef972421e66f71 (patch)
tree7bb57ca0aa38d23c324672d69eddc72d326d475b /src/vulkan/wsi/meson.build
parentc757fd2852849a5c8db92032ff66b6bbe5073f1c (diff)
vulkan/wsi/wayland: Add support for zwp_dmabuf
zwp_linux_dmabuf_v1 lets us use multi-planar images and buffer modifiers. Signed-off-by: Daniel Stone <[email protected]> Reviewed-by: Jason Ekstrand <[email protected]>
Diffstat (limited to 'src/vulkan/wsi/meson.build')
-rw-r--r--src/vulkan/wsi/meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/vulkan/wsi/meson.build b/src/vulkan/wsi/meson.build
index 66ccc8316ec..223c8ca357e 100644
--- a/src/vulkan/wsi/meson.build
+++ b/src/vulkan/wsi/meson.build
@@ -54,6 +54,8 @@ if with_platform_wayland
files_vulkan_wsi += [
wayland_drm_client_protocol_h,
wayland_drm_protocol_c,
+ linux_dmabuf_unstable_v1_client_protocol_h,
+ linux_dmabuf_unstable_v1_protocol_c,
]
endif