summaryrefslogtreecommitdiffstats
path: root/src/vulkan/tests/Makefile.am
diff options
context:
space:
mode:
authorJason Ekstrand <[email protected]>2015-08-14 15:24:01 -0700
committerJason Ekstrand <[email protected]>2015-08-14 17:04:39 -0700
commitb4c02253c4e1a7bc5a7a6369045210932f5de605 (patch)
tree50467894afbbcf4215db3a27dab9729846588536 /src/vulkan/tests/Makefile.am
parent16c5b9f4eda04d22c3c7b4cba0fe6303f149f86d (diff)
vk: Add four unit tests for our lock-free data-structures
Diffstat (limited to 'src/vulkan/tests/Makefile.am')
-rw-r--r--src/vulkan/tests/Makefile.am45
1 files changed, 45 insertions, 0 deletions
diff --git a/src/vulkan/tests/Makefile.am b/src/vulkan/tests/Makefile.am
new file mode 100644
index 00000000000..7b15bb002be
--- /dev/null
+++ b/src/vulkan/tests/Makefile.am
@@ -0,0 +1,45 @@
+# Copyright © 2009 Intel Corporation
+#
+# Permission is hereby granted, free of charge, to any person obtaining a
+# copy of this software and associated documentation files (the "Software"),
+# to deal in the Software without restriction, including without limitation
+# on the rights to use, copy, modify, merge, publish, distribute, sub
+# license, and/or sell copies of the Software, and to permit persons to whom
+# the Software is furnished to do so, subject to the following conditions:
+#
+# The above copyright notice and this permission notice (including the next
+# paragraph) shall be included in all copies or substantial portions of the
+# Software.
+#
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+# FITNESS FOR A PARTICULAR PURPOSE AND NON-INFRINGEMENT. IN NO EVENT SHALL
+# ADAM JACKSON BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER
+# IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN
+# CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
+
+AM_CPPFLAGS = \
+ $(INTEL_CFLAGS) \
+ $(VALGRIND_CFLAGS) \
+ $(DEFINES) \
+ -I$(top_srcdir)/include \
+ -I$(top_srcdir)/src \
+ -I$(top_srcdir)/src/mapi \
+ -I$(top_srcdir)/src/mesa \
+ -I$(top_srcdir)/src/mesa/drivers/dri/common \
+ -I$(top_srcdir)/src/mesa/drivers/dri/i965 \
+ -I$(top_srcdir)/src/gallium/auxiliary \
+ -I$(top_srcdir)/src/gallium/include \
+ -I$(top_srcdir)/src/vulkan
+
+LDADD = \
+ $(top_builddir)/src/vulkan/libvulkan-test.la \
+ $(PTHREAD_LIBS) -lm -lstdc++
+
+check_PROGRAMS = \
+ block_pool_no_free \
+ state_pool_no_free \
+ state_pool_free_list_only \
+ state_pool
+
+TESTS = $(check_PROGRAMS)