aboutsummaryrefslogtreecommitdiffstats
path: root/src/vulkan/Makefile.am
diff options
context:
space:
mode:
authorChad Versace <[email protected]>2017-08-15 16:48:38 -0700
committerChad Versace <[email protected]>2017-09-18 14:26:54 -0700
commit2d1fac119fa0d1fccae086605b43b426312b257a (patch)
tree3d01b8d22c49544a433fad86b31cf5ed2e425dde /src/vulkan/Makefile.am
parent7f57e58e2777c0e2c82cdf8de49d9cfa1ac9e6b1 (diff)
vulkan/registry: Feed vk_android_native_buffer.xml to gen_enum_to_str.py
Tested on Android and Fedora. Reviewed-by: Tapani Pälli <[email protected]>
Diffstat (limited to 'src/vulkan/Makefile.am')
-rw-r--r--src/vulkan/Makefile.am9
1 files changed, 7 insertions, 2 deletions
diff --git a/src/vulkan/Makefile.am b/src/vulkan/Makefile.am
index c897a07d6a8..c92748cb8a1 100644
--- a/src/vulkan/Makefile.am
+++ b/src/vulkan/Makefile.am
@@ -4,6 +4,7 @@ noinst_LTLIBRARIES = libvulkan_wsi.la libvulkan_util.la
vulkan_includedir = $(includedir)/vulkan
vulkan_api_xml = $(top_srcdir)/src/vulkan/registry/vk.xml
+vk_android_native_buffer_xml = $(top_srcdir)/src/vulkan/registry/vk_android_native_buffer.xml
MKDIR_GEN = $(AM_V_at)$(MKDIR_P) $(@D)
PYTHON_GEN = $(AM_V_GEN)$(PYTHON2) $(PYTHON_FLAGS)
@@ -18,9 +19,13 @@ VULKAN_UTIL_SOURCES = \
BUILT_SOURCES = \
$(VULKAN_UTIL_GENERATED_FILES)
-util/vk_enum_to_str.c util/vk_enum_to_str.h: util/gen_enum_to_str.py $(vulkan_api_xml)
+util/vk_enum_to_str.c util/vk_enum_to_str.h: util/gen_enum_to_str.py \
+ $(vulkan_api_xml) $(vk_android_native_buffer_xml)
$(MKDIR_GEN)
- $(PYTHON_GEN) $(srcdir)/util/gen_enum_to_str.py --xml $(vulkan_api_xml) --outdir $(top_builddir)/src/vulkan/util
+ $(PYTHON_GEN) $(srcdir)/util/gen_enum_to_str.py \
+ --xml $(vulkan_api_xml) \
+ --xml $(vk_android_native_buffer_xml) \
+ --outdir $(top_builddir)/src/vulkan/util
libvulkan_util_la_SOURCES = $(VULKAN_UTIL_SOURCES)