summaryrefslogtreecommitdiffstats
path: root/src/vulkan/Makefile.am
diff options
context:
space:
mode:
authorJason Ekstrand <[email protected]>2015-09-04 19:18:50 -0700
committerJason Ekstrand <[email protected]>2015-09-04 19:18:52 -0700
commit2c4ae00db693b066c479150998ca618265bf9d5c (patch)
tree71a3c94c2dcb062bd39f41cb939f430a3c6bd66d /src/vulkan/Makefile.am
parentb3c037f329beb5d7a63a7e755ca3b15acdfce972 (diff)
vk: Conditionally compile Wayland support
Pulling in libwayland causes undefined symbols in applications that are linked against vulkan alone. Ideally, we would like to dlopen a platform support library or something like that. For now, this works and should get crucible running again.
Diffstat (limited to 'src/vulkan/Makefile.am')
-rw-r--r--src/vulkan/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/src/vulkan/Makefile.am b/src/vulkan/Makefile.am
index 014183c0f71..b2eb4fb1cb1 100644
--- a/src/vulkan/Makefile.am
+++ b/src/vulkan/Makefile.am
@@ -75,7 +75,6 @@ VULKAN_SOURCES = \
anv_query.c \
anv_util.c \
anv_wsi.c \
- anv_wsi_wayland.c \
anv_wsi_x11.c \
gen8_state.c \
gen8_cmd_buffer.c \
@@ -84,6 +83,11 @@ VULKAN_SOURCES = \
gen7_cmd_buffer.c \
gen7_pipeline.c
+if HAVE_EGL_PLATFORM_WAYLAND
+VULKAN_SOURCES += anv_wsi_wayland.c
+libvulkan_la_CFLAGS += -DHAVE_WAYLAND_PLATFORM
+endif
+
libvulkan_la_SOURCES = \
$(VULKAN_SOURCES) \
anv_gem.c