summaryrefslogtreecommitdiffstats
path: root/src/vulkan/Makefile.am
diff options
context:
space:
mode:
authorDaniel Stone <[email protected]>2018-02-09 15:43:30 -0800
committerDaniel Stone <[email protected]>2018-02-21 22:37:10 +0000
commitbfa22266cd4d268e52d2535b41ef972421e66f71 (patch)
tree7bb57ca0aa38d23c324672d69eddc72d326d475b /src/vulkan/Makefile.am
parentc757fd2852849a5c8db92032ff66b6bbe5073f1c (diff)
vulkan/wsi/wayland: Add support for zwp_dmabuf
zwp_linux_dmabuf_v1 lets us use multi-planar images and buffer modifiers. Signed-off-by: Daniel Stone <[email protected]> Reviewed-by: Jason Ekstrand <[email protected]>
Diffstat (limited to 'src/vulkan/Makefile.am')
-rw-r--r--src/vulkan/Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/src/vulkan/Makefile.am b/src/vulkan/Makefile.am
index 4fdaedf38c1..c7813ce05e3 100644
--- a/src/vulkan/Makefile.am
+++ b/src/vulkan/Makefile.am
@@ -71,6 +71,16 @@ wsi/wayland-drm-client-protocol.h : $(WL_DRM_XML)
$(MKDIR_GEN)
$(AM_V_GEN)$(WAYLAND_SCANNER) client-header < $< > $@
+WL_DMABUF_XML = $(WAYLAND_PROTOCOLS_DATADIR)/unstable/linux-dmabuf/linux-dmabuf-unstable-v1.xml
+
+wsi/linux-dmabuf-unstable-v1-protocol.c : $(WL_DMABUF_XML)
+ $(MKDIR_GEN)
+ $(AM_V_GEN)$(WAYLAND_SCANNER) code < $< > $@
+
+wsi/linux-dmabuf-unstable-v1-client-protocol.h : $(WL_DMABUF_XML)
+ $(MKDIR_GEN)
+ $(AM_V_GEN)$(WAYLAND_SCANNER) client-header < $< > $@
+
if HAVE_PLATFORM_WAYLAND
AM_CPPFLAGS += \
-I$(top_builddir)/src/vulkan/wsi \