summaryrefslogtreecommitdiffstats
path: root/src/vulkan/Makefile.am
diff options
context:
space:
mode:
authorJason Ekstrand <[email protected]>2015-10-19 22:06:59 -0700
committerJason Ekstrand <[email protected]>2015-10-20 13:02:03 -0700
commita71e614d33e8d869bbaced8948349a7180783ab7 (patch)
tree0194c7cf955a3c4f15c67cab53b388389a828574 /src/vulkan/Makefile.am
parent2d9e899e3576120f1a671c6cc38835b41269e607 (diff)
anv: Completely rework shader compilation
Now that we have a decent interface in upstream mesa, we can get rid of all our hacks. As of this commit, we no longer use any fake GL state objects and all of shader compilation is moved into anv_pipeline.c. This should make way for actually implementing a shader cache one of these days. As a nice side-benifit, this commit also gains us an extra 300 passing CTS tests because we're actually filling out the texture swizzle information for vertex shaders.
Diffstat (limited to 'src/vulkan/Makefile.am')
-rw-r--r--src/vulkan/Makefile.am7
1 files changed, 1 insertions, 6 deletions
diff --git a/src/vulkan/Makefile.am b/src/vulkan/Makefile.am
index 5abbd379b54..8538046e567 100644
--- a/src/vulkan/Makefile.am
+++ b/src/vulkan/Makefile.am
@@ -55,14 +55,10 @@ libvulkan_la_CFLAGS = \
-Wall -Wno-unused-parameter -fvisibility=hidden -O0 -g \
-Wstrict-prototypes -Wmissing-prototypes -Wno-override-init
-libvulkan_la_CXXFLAGS = \
- -Wall -Wno-unused-parameter -fvisibility=hidden -O0 -g
-
VULKAN_SOURCES = \
anv_allocator.c \
anv_cmd_buffer.c \
anv_batch_chain.c \
- anv_compiler.cpp \
anv_device.c \
anv_dump.c \
anv_entrypoints.c \
@@ -124,7 +120,7 @@ libvulkan_la_LIBADD = $(WAYLAND_LIBS) -lxcb -lxcb-dri3 \
$(top_builddir)/src/mesa/drivers/dri/i965/libi965_compiler.la \
../mesa/libmesa.la \
../mesa/drivers/dri/common/libdri_test_stubs.la \
- -lpthread -ldl
+ -lpthread -ldl -lstdc++
# Libvulkan with dummy gem. Used for unit tests.
@@ -133,7 +129,6 @@ libvulkan_test_la_SOURCES = \
anv_gem_stubs.c
libvulkan_test_la_CFLAGS = $(libvulkan_la_CFLAGS)
-libvulkan_test_la_CXXFLAGS = $(libvulkan_la_CXXFLAGS)
libvulkan_test_la_LIBADD = $(libvulkan_la_LIBADD)
include $(top_srcdir)/install-lib-links.mk