summaryrefslogtreecommitdiffstats
path: root/src/vulkan/Makefile.am
diff options
context:
space:
mode:
authorEmil Velikov <[email protected]>2016-11-27 00:25:28 +0000
committerEmil Velikov <[email protected]>2017-05-19 19:44:15 +0100
commitacf3d2afab0571b74c0c0d1aee0f631b33fdc7da (patch)
treea14f1e451c4f601340d0b2ab7063f72a98f1769e /src/vulkan/Makefile.am
parent8212fc95b59d0dd3cae1fe11359e0fa96d75e1bc (diff)
configure: check once for DRI3 dependencies
Currently we are having the XCB_DRI3 dependencies duplicated, partially. Just do a once-off check and add all of the respective CFLAGS/LIBS where needed. As a nice side effect this helps us solve a couple of FIXMEs. DRI3 is not a thing w/o X11 so disable it in such cases. Cc: [email protected] Signed-off-by: Emil Velikov <[email protected]> Reviewed-by: Eric Engestrom <[email protected]>
Diffstat (limited to 'src/vulkan/Makefile.am')
-rw-r--r--src/vulkan/Makefile.am3
1 files changed, 1 insertions, 2 deletions
diff --git a/src/vulkan/Makefile.am b/src/vulkan/Makefile.am
index bd66901255d..c48245c22c9 100644
--- a/src/vulkan/Makefile.am
+++ b/src/vulkan/Makefile.am
@@ -44,8 +44,7 @@ AM_CPPFLAGS += \
VULKAN_WSI_SOURCES += $(VULKAN_WSI_X11_FILES)
-# FIXME: Use pkg-config for X11-xcb ldflags.
-VULKAN_LIB_DEPS += $(XCB_DRI3_LIBS) -lX11-xcb
+VULKAN_LIB_DEPS += $(XCB_DRI3_LIBS)
endif
BUILT_SOURCES += $(VULKAN_WSI_WAYLAND_GENERATED_FILES)