aboutsummaryrefslogtreecommitdiffstats
path: root/src/vulkan/Makefile.am
diff options
context:
space:
mode:
authorKristian Høgsberg Kristensen <[email protected]>2015-12-04 17:13:26 -0800
committerKristian Høgsberg Kristensen <[email protected]>2015-12-04 21:24:15 -0800
commit7337870036263518ccac75758bdaa415c28a2c1a (patch)
tree076099a2e3ac5eab2d3d08509501d1a0ffeaaadb /src/vulkan/Makefile.am
parent2f270f0d15eba2b1ac0a86cf6ebb8e2cb0767d8a (diff)
vk: Move isl files to libisl.la helper library
These will be in their own library eventually - let's just do that now.
Diffstat (limited to 'src/vulkan/Makefile.am')
-rw-r--r--src/vulkan/Makefile.am10
1 files changed, 7 insertions, 3 deletions
diff --git a/src/vulkan/Makefile.am b/src/vulkan/Makefile.am
index 5651f661e05..7c108e4b145 100644
--- a/src/vulkan/Makefile.am
+++ b/src/vulkan/Makefile.am
@@ -44,7 +44,7 @@ PER_GEN_LIBS = \
libanv-gen8.la \
libanv-gen9.la
-noinst_LTLIBRARIES = $(PER_GEN_LIBS)
+noinst_LTLIBRARIES = $(PER_GEN_LIBS) libisl.la
# The gallium includes are for the util/u_math.h include from main/macros.h
@@ -92,7 +92,11 @@ VULKAN_SOURCES = \
anv_query.c \
anv_util.c \
anv_wsi.c \
- anv_wsi_x11.c \
+ anv_wsi_x11.c
+
+libisl_la_CFLAGS = $(libvulkan_la_CFLAGS)
+
+libisl_la_SOURCES = \
isl.c \
isl_format_layout.c \
isl_gen4.c \
@@ -180,7 +184,7 @@ libvulkan_la_LIBADD = $(WAYLAND_LIBS) -lxcb -lxcb-dri3 \
../mesa/libmesa.la \
../mesa/drivers/dri/common/libdri_test_stubs.la \
-lpthread -ldl -lstdc++ \
- $(PER_GEN_LIBS)
+ $(PER_GEN_LIBS) libisl.la
# Libvulkan with dummy gem. Used for unit tests.