aboutsummaryrefslogtreecommitdiffstats
path: root/src/vulkan/Makefile.am
diff options
context:
space:
mode:
authorJason Ekstrand <[email protected]>2015-10-16 20:01:45 -0700
committerJason Ekstrand <[email protected]>2015-10-16 20:03:06 -0700
commit7010fe61c8c72ce9bc8df98d730d99652333d460 (patch)
treea44dee98197cb00ea8b8b3f6a70e98be1db2a11b /src/vulkan/Makefile.am
parent368e703a01c631f04f2a2a1f5f62f61c06838fae (diff)
anv: Add facilities for dumping an image to a file
The ability to dump an arbitrary miplevel or array slice of an anv_image to a file is very useful for debugging. Nothing inside of the driver calls this right now, but it's very useful to call from GDB.
Diffstat (limited to 'src/vulkan/Makefile.am')
-rw-r--r--src/vulkan/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/vulkan/Makefile.am b/src/vulkan/Makefile.am
index aeed78ae840..985864a87fe 100644
--- a/src/vulkan/Makefile.am
+++ b/src/vulkan/Makefile.am
@@ -63,6 +63,7 @@ VULKAN_SOURCES = \
anv_batch_chain.c \
anv_compiler.cpp \
anv_device.c \
+ anv_dump.c \
anv_entrypoints.c \
anv_entrypoints.h \
anv_formats.c \