aboutsummaryrefslogtreecommitdiffstats
path: root/src/vulkan/Makefile.am
diff options
context:
space:
mode:
authorJason Ekstrand <[email protected]>2015-10-29 22:24:54 -0700
committerJason Ekstrand <[email protected]>2015-10-29 22:26:36 -0700
commit3883728730f293b763a5641560375b18d4f97782 (patch)
treec4f5524a0eee4662ad0b7abb8dfd3a40c304fb3e /src/vulkan/Makefile.am
parent1f2624e6dd75860156a0385c3ccfb351a9206cec (diff)
anv: Add better push constant support
What we had before was kind of a hack where we made certain untrue assumptions about the incoming data. This new support, while it still doesn't support indirects properly (that will come), at least pulls the offsets and strides from SPIR-V like it's supposed to.
Diffstat (limited to 'src/vulkan/Makefile.am')
-rw-r--r--src/vulkan/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/vulkan/Makefile.am b/src/vulkan/Makefile.am
index 475fa4f2ad2..0d6c9df6b67 100644
--- a/src/vulkan/Makefile.am
+++ b/src/vulkan/Makefile.am
@@ -69,6 +69,7 @@ VULKAN_SOURCES = \
anv_meta.c \
anv_nir_apply_dynamic_offsets.c \
anv_nir_apply_pipeline_layout.c \
+ anv_nir_lower_push_constants.c \
anv_pass.c \
anv_pipeline.c \
anv_private.h \