aboutsummaryrefslogtreecommitdiffstats
path: root/src/vulkan/Makefile.am
diff options
context:
space:
mode:
authorJason Ekstrand <[email protected]>2015-10-02 16:20:02 -0700
committerJason Ekstrand <[email protected]>2015-10-02 16:20:04 -0700
commit002e7b0cc3c34c626fede219903b8b086a14ae5a (patch)
tree945b7b8d65d0f8aa7aedfcf0538703bdafd1e2eb /src/vulkan/Makefile.am
parentf5ffb0e0cbdc2da7c2b03258fde2a0f27c563a7a (diff)
anv: Remove the GLSL -> SPIR-V scraper/converter
This was very useful to get us up-and-going. However, now that we can use NIR directly for meta shaders, we don't need this anymore and we might as well drop the glslc dependency.
Diffstat (limited to 'src/vulkan/Makefile.am')
-rw-r--r--src/vulkan/Makefile.am3
1 files changed, 0 insertions, 3 deletions
diff --git a/src/vulkan/Makefile.am b/src/vulkan/Makefile.am
index aada6314b2a..765d2cef03d 100644
--- a/src/vulkan/Makefile.am
+++ b/src/vulkan/Makefile.am
@@ -116,9 +116,6 @@ anv_entrypoints.h : anv_entrypoints_gen.py $(vulkan_include_HEADERS)
anv_entrypoints.c : anv_entrypoints_gen.py $(vulkan_include_HEADERS)
$(AM_V_GEN)cat $(vulkan_include_HEADERS) | $(PYTHON2) $< code > $@
-%_spirv_autogen.h: %.c glsl_scraper.py
- $(AM_V_GEN) $(PYTHON3) $(srcdir)/glsl_scraper.py --with-glslc=$(GLSLC) -o $@ $<
-
CLEANFILES = $(BUILT_SOURCES)
libvulkan_la_LIBADD = $(WAYLAND_LIBS) -lxcb -lxcb-dri3 \