summaryrefslogtreecommitdiffstats
path: root/src/util/xmlpool/meson.build
diff options
context:
space:
mode:
authorDylan Baker <[email protected]>2018-10-24 12:20:48 -0700
committerDylan Baker <[email protected]>2018-10-31 16:37:46 -0700
commitb9cd81ea3189ffdf847377ebbc11a676dc302a6f (patch)
tree4a0566df4b27d29652dbd735d79fd58c5539933e /src/util/xmlpool/meson.build
parent1df086662a993340127637f88cfe0462b48e66c8 (diff)
util/gen_xmlpool: Don't write via shell redirection
Using shell redirection to write to a file is more complicated than necessary, and has the potential to run into unicode encoding problems. It's also less code. Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=108530 v2: - update commit message to say less about LANG=C - use flags instead of positional arguments for the script (Emil) Reviewed-by: Emil Velikov <[email protected]>
Diffstat (limited to 'src/util/xmlpool/meson.build')
-rw-r--r--src/util/xmlpool/meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/util/xmlpool/meson.build b/src/util/xmlpool/meson.build
index ae7c951a097..1fce397e472 100644
--- a/src/util/xmlpool/meson.build
+++ b/src/util/xmlpool/meson.build
@@ -30,9 +30,9 @@ xmlpool_options_h = custom_target(
input : ['gen_xmlpool.py', 't_options.h'],
output : 'options.h',
command : [
- prog_python, '@INPUT@', meson.current_build_dir(), _langs,
+ prog_python, '@INPUT0@', '--template', '@INPUT1@', '--output', '@OUTPUT@',
+ '--localedir', meson.current_build_dir(), '--languages', _langs,
],
- capture : true,
depend_files : _langs_po_files,
)