summaryrefslogtreecommitdiffstats
path: root/src/util/tests/timespec/meson.build
diff options
context:
space:
mode:
authorLionel Landwerlin <[email protected]>2019-07-29 12:54:04 +0300
committerLionel Landwerlin <[email protected]>2019-07-29 13:11:36 +0000
commitd2d70c3bb579f8a8e0b7431eff164e85ca7bc4ab (patch)
tree428f40ae148a26c3124c00f80ba70750354c55dd /src/util/tests/timespec/meson.build
parentef57fb235016a168b0f2260783c44c7f4ebea32d (diff)
util: add a timespec helper
Copied from Weston, upon Daniel's suggestion Signed-off-by: Lionel Landwerlin <[email protected]> Suggested-by: Daniel Stone <[email protected]> Reviewed-by: Daniel Stone <[email protected]>
Diffstat (limited to 'src/util/tests/timespec/meson.build')
-rw-r--r--src/util/tests/timespec/meson.build31
1 files changed, 31 insertions, 0 deletions
diff --git a/src/util/tests/timespec/meson.build b/src/util/tests/timespec/meson.build
new file mode 100644
index 00000000000..aa801bee188
--- /dev/null
+++ b/src/util/tests/timespec/meson.build
@@ -0,0 +1,31 @@
+# Copyright © 2019 Intel Corporation
+
+# Permission is hereby granted, free of charge, to any person obtaining a copy
+# of this software and associated documentation files (the "Software"), to deal
+# in the Software without restriction, including without limitation the rights
+# to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+# copies of the Software, and to permit persons to whom the Software is
+# furnished to do so, subject to the following conditions:
+
+# The above copyright notice and this permission notice shall be included in
+# all copies or substantial portions of the Software.
+
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+# AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+# LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+# OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+# SOFTWARE.
+
+test(
+ 'timespec',
+ executable(
+ 'timespec_test',
+ 'timespec_test.cpp',
+ dependencies : [dep_thread, dep_dl, idep_gtest],
+ include_directories : inc_common,
+ link_with : [libmesa_util],
+ ),
+ suite : ['util'],
+)