summaryrefslogtreecommitdiffstats
path: root/src/util/tests/hash_table/Makefile.am
diff options
context:
space:
mode:
authorKenneth Graunke <[email protected]>2014-02-25 01:08:45 -0800
committerJason Ekstrand <[email protected]>2014-08-04 11:07:05 -0700
commit72e55bb6888ff4d6b69b10d9c58573e4c3d492ec (patch)
tree9084fd3c939f545bbc0d6a214564755bca9745cb /src/util/tests/hash_table/Makefile.am
parent1e0da6233be6e5fb0143615d5e3d3642ddb7964f (diff)
util: Move the open-addressing linear-probing hash_table to src/util.
This hash table is used in core Mesa, the GLSL compiler, and the i965 driver, which makes it a good candidate for the new src/util module. It's much faster than program/hash_table.[ch] (see commit 6991c2922f5 for data), and José's u_hash_table.c has a comment saying Gallium should probably consider switching to a linear probing hash table at some point. So this seems like the best candidate for a shared data structure. Signed-off-by: Kenneth Graunke <[email protected]> v2 (Jason Ekstrand): Pick up another hash_table use and patch up scons Signed-off-by: Jason Ekstrand <[email protected]> Reviewed-by: Marek Olšák <[email protected]>
Diffstat (limited to 'src/util/tests/hash_table/Makefile.am')
-rw-r--r--src/util/tests/hash_table/Makefile.am46
1 files changed, 46 insertions, 0 deletions
diff --git a/src/util/tests/hash_table/Makefile.am b/src/util/tests/hash_table/Makefile.am
new file mode 100644
index 00000000000..55cc0b72335
--- /dev/null
+++ b/src/util/tests/hash_table/Makefile.am
@@ -0,0 +1,46 @@
+# Copyright © 2009 Intel Corporation
+#
+# Permission is hereby granted, free of charge, to any person obtaining a
+# copy of this software and associated documentation files (the "Software"),
+# to deal in the Software without restriction, including without limitation
+# on the rights to use, copy, modify, merge, publish, distribute, sub
+# license, and/or sell copies of the Software, and to permit persons to whom
+# the Software is furnished to do so, subject to the following conditions:
+#
+# The above copyright notice and this permission notice (including the next
+# paragraph) shall be included in all copies or substantial portions of the
+# Software.
+#
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+# FITNESS FOR A PARTICULAR PURPOSE AND NON-INFRINGEMENT. IN NO EVENT SHALL
+# ADAM JACKSON BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER
+# IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN
+# CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
+
+AM_CPPFLAGS = \
+ -I$(top_srcdir)/include \
+ -I$(top_srcdir)/src/util \
+ -I$(top_srcdir)/src/mesa \
+ -I$(top_srcdir)/src/mesa/main \
+ $(DEFINES) $(INCLUDE_DIRS)
+
+LDADD = \
+ $(top_builddir)/src/mesa/libmesa.la \
+ $(PTHREAD_LIBS) \
+ $(DLOPEN_LIBS)
+
+TESTS = \
+ collision \
+ delete_and_lookup \
+ delete_management \
+ destroy_callback \
+ insert_and_lookup \
+ insert_many \
+ null_destroy \
+ random_entry \
+ remove_null \
+ replacement \
+ $()
+
+EXTRA_PROGRAMS = $(TESTS)