aboutsummaryrefslogtreecommitdiffstats
path: root/src/util/meson.build
diff options
context:
space:
mode:
authorDylan Baker <[email protected]>2018-07-10 15:00:13 -0700
committerDylan Baker <[email protected]>2018-08-01 12:47:16 -0700
commit17f49950da91137366910183f616d15b8bbf580c (patch)
tree4d3c1dbcf8c588a24adccba262d2d6dd4e9b5130 /src/util/meson.build
parentcb6b241c301d5352a5bcaab52bbfaf89e700b2b2 (diff)
util: move process.[ch] to u_process.[ch]
On windows process.h is a system provided header, and it's required in include/c11/threads_win32.h. This header interferes with searching for that header, and results in windows build warnings with scons, but errors in meson which doesn't allow implicit function declarations. Just rename process to u_process, which follows the style of utils anyway. Fixes: 2e1e6511f76370870b5cde10caa9ca3b6d0dc65f ("util: extract get_process_name from xmlconfig.c") Signed-off-by: Dylan Baker <[email protected]> Reviewed-by: Marek Olšák <[email protected]>
Diffstat (limited to 'src/util/meson.build')
-rw-r--r--src/util/meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/util/meson.build b/src/util/meson.build
index 8c91be8539c..6386d945a22 100644
--- a/src/util/meson.build
+++ b/src/util/meson.build
@@ -48,8 +48,8 @@ files_mesa_util = files(
'mesa-sha1.h',
'os_time.c',
'os_time.h',
- 'process.c',
- 'process.h',
+ 'u_process.c',
+ 'u_process.h',
'sha1/sha1.c',
'sha1/sha1.h',
'ralloc.c',