summaryrefslogtreecommitdiffstats
path: root/src/util/meson.build
diff options
context:
space:
mode:
authorPierre-Eric Pelloux-Prayer <[email protected]>2020-03-16 10:49:17 +0100
committerPierre-Eric Pelloux-Prayer <[email protected]>2020-03-24 08:30:34 +0100
commitf8f1413070ae079443ab31a75679cfd10cb756ed (patch)
treef1fc171c63cd2c4c4d07b6688573a796aed0b347 /src/util/meson.build
parent2cb965e5b60dbcd767da42360a5e18acd8803f5d (diff)
util/u_process: add util_get_process_exec_path
Reviewed-by: Marek Olšák <[email protected]> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/4181>
Diffstat (limited to 'src/util/meson.build')
-rw-r--r--src/util/meson.build22
1 files changed, 22 insertions, 0 deletions
diff --git a/src/util/meson.build b/src/util/meson.build
index ea61c055817..77e3973c1a0 100644
--- a/src/util/meson.build
+++ b/src/util/meson.build
@@ -278,6 +278,28 @@ if with_tests
suite : ['util'],
)
+ process_test_exe = executable(
+ 'process_test',
+ files('process_test.c'),
+ include_directories : inc_common,
+ dependencies : idep_mesautil,
+ c_args : [c_msvc_compat_args],
+ )
+ if not (host_machine.system() == 'windows')
+ process_test_exe_full_path = process_test_exe.full_path()
+ else
+ process_test_exe_full_path = run_command(
+ 'winepath', '-w', process_test_exe.full_path()
+ ).stdout().strip()
+ endif
+
+ test(
+ 'process',
+ process_test_exe,
+ suite : ['util'],
+ env: ['BUILD_FULL_PATH='+process_test_exe_full_path]
+ )
+
subdir('tests/fast_idiv_by_const')
subdir('tests/fast_urem_by_const')
subdir('tests/hash_table')