summaryrefslogtreecommitdiffstats
path: root/src/util/meson.build
diff options
context:
space:
mode:
authorSergii Romantsov <[email protected]>2018-09-07 12:43:41 +0300
committerDylan Baker <[email protected]>2018-09-10 08:57:42 -0700
commitbbe551f3eab793a18cd427098cf8563040c0b56f (patch)
tree017ce48e4693a597cdaaaf0a7d6fa0e05f20e370 /src/util/meson.build
parent52ca32121bc99d61cc30077fe37f85bdb4c47659 (diff)
mesa/meson: 32bit xmlconfig linkage
Building of 32bit mesa with meson causes linkage issue: "undefined reference to `util_get_process_name'" Fixed by adding link-with mesa_util for xmlconfig primary. v2: Removed '[]', commit message corrected. v3: Reverted changes in gbm and glx libraries. Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=107843 Fixes: 2e1e6511f76370870b5cd "util: extract get_process_name from xmlconfig.c" Cc: Marek Olšák <[email protected]> Cc: Dylan Baker <[email protected]> Signed-off-by: Sergii Romantsov <[email protected]> Reviewed-by: Eric Engestrom <[email protected]> Reviewed-by: Dylan Baker <[email protected]>
Diffstat (limited to 'src/util/meson.build')
-rw-r--r--src/util/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/util/meson.build b/src/util/meson.build
index e7ad2861238..027bc5b9d0d 100644
--- a/src/util/meson.build
+++ b/src/util/meson.build
@@ -119,6 +119,7 @@ libxmlconfig = static_library(
'xmlconfig',
files_xmlconfig,
include_directories : inc_common,
+ link_with : libmesa_util,
dependencies : [dep_expat, dep_m],
c_args : [
c_msvc_compat_args, c_vis_args,