summaryrefslogtreecommitdiffstats
path: root/src/util/meson.build
diff options
context:
space:
mode:
authorScott D Phillips <[email protected]>2018-05-04 17:11:13 -0700
committerJason Ekstrand <[email protected]>2018-05-31 16:51:35 -0700
commit943fecc5691b55b8ce8740d133dd70614effb72d (patch)
treeaa5bd576ca6fb71554e742460c69e90a86588a17 /src/util/meson.build
parentf19ad5d31fde8c447119c5483b3e3972922e9991 (diff)
util: Add a randomized test for the virtual memory allocator
The test pseudo-randomly makes allocations and deallocations with the virtual memory allocator and checks that the results are consistent. Specifically, we test that: * no result from the allocator overlaps an already allocated range * allocated memory fulfills the stated alignment requirement * a failed result from the allocator could not have been fulfilled * memory freed to the allocator can later be allocated again v2: - fix if() in test() to actually run fill() v3: - add c++11 build flag (Jason) - test the full 64-bit range (Jason) Reviewed-by: Jason Ekstrand <[email protected]>
Diffstat (limited to 'src/util/meson.build')
-rw-r--r--src/util/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/util/meson.build b/src/util/meson.build
index 14660e0fa0c..c777984e28d 100644
--- a/src/util/meson.build
+++ b/src/util/meson.build
@@ -159,4 +159,5 @@ if with_tests
subdir('tests/hash_table')
subdir('tests/string_buffer')
+ subdir('tests/vma')
endif