summaryrefslogtreecommitdiffstats
path: root/src/util/meson.build
diff options
context:
space:
mode:
authorEric Engestrom <[email protected]>2019-03-05 16:21:47 +0000
committerEric Engestrom <[email protected]>2020-03-28 21:36:54 +0100
commit79af30768d6cf8e28c7cf49f99fff6c2b2cb030b (patch)
tree2959579481faa474f5599c2d3491456c2259235a /src/util/meson.build
parent5a32dda8e6f5780ed5e0927486f5eb4971d0162b (diff)
meson: inline `inc_common`
Let's make it clear what includes are being added everywhere, so that they can be cleaned up. Signed-off-by: Eric Engestrom <[email protected]> Reviewed-by: Marek Olšák <[email protected]> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/4360>
Diffstat (limited to 'src/util/meson.build')
-rw-r--r--src/util/meson.build18
1 files changed, 9 insertions, 9 deletions
diff --git a/src/util/meson.build b/src/util/meson.build
index d6647c0c5c3..0a2b2e4284e 100644
--- a/src/util/meson.build
+++ b/src/util/meson.build
@@ -170,7 +170,7 @@ endif
_libmesa_util = static_library(
'mesa_util',
[files_mesa_util, format_srgb],
- include_directories : inc_common,
+ include_directories : [inc_include, inc_src, inc_mapi, inc_mesa, inc_gallium, inc_gallium_aux],
dependencies : deps_for_libmesa_util,
link_with: libmesa_format,
c_args : [c_msvc_compat_args, c_vis_args],
@@ -186,7 +186,7 @@ idep_mesautil = declare_dependency(
_libxmlconfig = static_library(
'xmlconfig',
files_xmlconfig,
- include_directories : inc_common,
+ include_directories : [inc_include, inc_src, inc_mapi, inc_mesa, inc_gallium, inc_gallium_aux],
dependencies : [idep_mesautil, dep_expat, dep_m],
c_args : [
c_msvc_compat_args, c_vis_args,
@@ -211,7 +211,7 @@ if with_tests
executable(
'u_atomic_test',
files('u_atomic_test.c'),
- include_directories : inc_common,
+ include_directories : [inc_include, inc_src, inc_mapi, inc_mesa, inc_gallium, inc_gallium_aux],
dependencies : idep_mesautil,
c_args : [c_msvc_compat_args],
),
@@ -223,7 +223,7 @@ if with_tests
executable(
'blob_test',
files('blob_test.c'),
- include_directories : inc_common,
+ include_directories : [inc_include, inc_src, inc_mapi, inc_mesa, inc_gallium, inc_gallium_aux],
dependencies : idep_mesautil,
c_args : [c_msvc_compat_args],
),
@@ -235,7 +235,7 @@ if with_tests
executable(
'rb_tree_test',
files('rb_tree_test.c'),
- include_directories : inc_common,
+ include_directories : [inc_include, inc_src, inc_mapi, inc_mesa, inc_gallium, inc_gallium_aux],
dependencies : idep_mesautil,
c_args : [c_msvc_compat_args],
),
@@ -247,7 +247,7 @@ if with_tests
executable(
'roundeven_test',
files('roundeven_test.c'),
- include_directories : inc_common,
+ include_directories : [inc_include, inc_src, inc_mapi, inc_mesa, inc_gallium, inc_gallium_aux],
c_args : [c_msvc_compat_args],
dependencies : [dep_m],
),
@@ -262,7 +262,7 @@ if with_tests
executable(
'mesa-sha1_test',
files('mesa-sha1_test.c'),
- include_directories : inc_common,
+ include_directories : [inc_include, inc_src, inc_mapi, inc_mesa, inc_gallium, inc_gallium_aux],
link_with : _libmesa_util,
c_args : [c_msvc_compat_args],
),
@@ -275,7 +275,7 @@ if with_tests
executable(
'bitset_test',
files('bitset_test.cpp'),
- include_directories : inc_common,
+ include_directories : [inc_include, inc_src, inc_mapi, inc_mesa, inc_gallium, inc_gallium_aux],
dependencies : [idep_mesautil, idep_gtest],
),
suite : ['util'],
@@ -284,7 +284,7 @@ if with_tests
process_test_exe = executable(
'process_test',
files('process_test.c'),
- include_directories : inc_common,
+ include_directories : [inc_include, inc_src, inc_mapi, inc_mesa, inc_gallium, inc_gallium_aux],
dependencies : idep_mesautil,
c_args : [c_msvc_compat_args],
)