summaryrefslogtreecommitdiffstats
path: root/src/util/meson.build
diff options
context:
space:
mode:
authorJason Ekstrand <[email protected]>2018-09-13 09:56:20 -0500
committerJason Ekstrand <[email protected]>2018-10-10 13:13:12 -0500
commit328d4d080bce128ff422fbfbd7271ef4ede38320 (patch)
tree6e557472267ec1a2cfa0b69122c76b9a7c5931cc /src/util/meson.build
parenta9be8dddfedb1d19e43b900bdfd33731d3c390c4 (diff)
util: Add tests for fast integer division by constants
While I generally trust rediculousfish to have done his homework, we've made some adjustments to suit the needs of mesa and it'd be good to test those. Also, there's no better place than unit tests to clearly document the different edge cases of the different methods. Reviewed-by: Marek Olšák <[email protected]>
Diffstat (limited to 'src/util/meson.build')
-rw-r--r--src/util/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/util/meson.build b/src/util/meson.build
index cdbad98e7cb..49d84c16ebe 100644
--- a/src/util/meson.build
+++ b/src/util/meson.build
@@ -170,6 +170,7 @@ if with_tests
)
)
+ subdir('tests/fast_idiv_by_const')
subdir('tests/hash_table')
subdir('tests/string_buffer')
subdir('tests/vma')