summaryrefslogtreecommitdiffstats
path: root/src/util/meson.build
diff options
context:
space:
mode:
authorSergii Romantsov <[email protected]>2018-11-01 13:02:43 +0200
committerLionel Landwerlin <[email protected]>2018-11-05 13:21:49 +0100
commitce837a537282f10bc48c4ac426fa9a31241beea2 (patch)
tree21dfbf1766226245e4ad3a273b39b35b003971c1 /src/util/meson.build
parentf7fd0d86a98c94a4d0efa5a4f778badce7121a51 (diff)
autotools: library-dependency when no sse and 32-bit
Building of 32bit Mesa may fail if __SSE__ is not specified. Added missed dependency from libm. v2: avoided dependecy on any flag, just link v3: meson doesn't fail, but have added dependency on libm CC: Dylan Baker <[email protected]> CC: Lionel G Landwerlin <[email protected]> Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=108560 Signed-off-by: Sergii Romantsov <[email protected]> Reviewed-by: Dylan Baker <[email protected]>
Diffstat (limited to 'src/util/meson.build')
-rw-r--r--src/util/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/util/meson.build b/src/util/meson.build
index 7caea27d660..156621aff65 100644
--- a/src/util/meson.build
+++ b/src/util/meson.build
@@ -119,7 +119,7 @@ libmesa_util = static_library(
'mesa_util',
[files_mesa_util, format_srgb],
include_directories : inc_common,
- dependencies : [dep_zlib, dep_clock, dep_thread, dep_atomic],
+ dependencies : [dep_zlib, dep_clock, dep_thread, dep_atomic, dep_m],
c_args : [c_msvc_compat_args, c_vis_args],
build_by_default : false
)