summaryrefslogtreecommitdiffstats
path: root/src/util/meson.build
diff options
context:
space:
mode:
authorConnor Abbott <[email protected]>2019-03-29 15:08:17 +0100
committerConnor Abbott <[email protected]>2019-05-31 19:14:27 +0200
commitb87817871b615af960c2d84e35d41b88602c4186 (patch)
tree519a15d65aada0f193a5bcdbc1adfe2d6b4817df /src/util/meson.build
parent983b001c77c6c9e9aa436c3252fafe34edfe6738 (diff)
util: Add a helper for faster remainders
This should be at least as fast as using fast_idiv_by_const, and has the advantage that the precomputation is simple enough to be evaluated at Mesa-compile time for hash tables and sets which have a fixed table of possible divisors. Acked-by: Eric Anholt <[email protected]> Acked-by: Jason Ekstrand <[email protected]>
Diffstat (limited to 'src/util/meson.build')
-rw-r--r--src/util/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/util/meson.build b/src/util/meson.build
index dbb903218f2..23f8c68c701 100644
--- a/src/util/meson.build
+++ b/src/util/meson.build
@@ -208,6 +208,7 @@ if with_tests
)
subdir('tests/fast_idiv_by_const')
+ subdir('tests/fast_urem_by_const')
subdir('tests/hash_table')
subdir('tests/string_buffer')
subdir('tests/vma')