aboutsummaryrefslogtreecommitdiffstats
path: root/src/util/meson.build
diff options
context:
space:
mode:
authorEric Anholt <[email protected]>2019-06-27 15:05:31 -0700
committerEric Anholt <[email protected]>2019-11-14 10:47:20 -0800
commit882ca6dfb0f3d17e0f8bc917307d915ab1718069 (patch)
tree652b9932fc1182d4d191d7970fcd10c3687fbd3b /src/util/meson.build
parentac78ca4b39ce6e927f824b928d17f30c1d9273ce (diff)
util: Move gallium's PIPE_FORMAT utils to /util/format/
To make PIPE_FORMATs usable from non-gallium parts of Mesa, I want to move their helpers out of gallium. Since u_format used util_copy_rect(), I moved that in there, too. I've put it in a separate directory in util/ because it's a big chunk of related code, and it's not clear to me whether we might want it as a separate library from libmesa_util at some point. Closes: #1905 Acked-by: Marek Olšák <[email protected]> Reviewed-by: Kristian H. Kristensen <[email protected]> Reviewed-by: Alyssa Rosenzweig <[email protected]>
Diffstat (limited to 'src/util/meson.build')
-rw-r--r--src/util/meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/util/meson.build b/src/util/meson.build
index a7990ad52cc..9300cb6e34a 100644
--- a/src/util/meson.build
+++ b/src/util/meson.build
@@ -20,6 +20,7 @@
inc_util = include_directories('.')
+subdir('format')
subdir('xmlpool')
files_mesa_util = files(
@@ -161,6 +162,7 @@ _libmesa_util = static_library(
[files_mesa_util, format_srgb],
include_directories : inc_common,
dependencies : deps_for_libmesa_util,
+ link_with: libmesa_format,
c_args : [c_msvc_compat_args, c_vis_args],
build_by_default : false
)