summaryrefslogtreecommitdiffstats
path: root/src/util/Makefile.am
diff options
context:
space:
mode:
authorQiang Yu <[email protected]>2018-08-06 11:41:33 +0800
committerEmil Velikov <[email protected]>2018-08-17 17:16:32 +0100
commit04bdbbcab3c4862bf3f54ce60fcc1d2007776f80 (patch)
treed078e5edb23a74a3aa5ac0e5ea371103b46ece7e /src/util/Makefile.am
parent0da417129e070193091452c8ffdec4df12070bc6 (diff)
xmlconfig: read more config files from drirc.d/
Driver and application can put their drirc files in ${datadir}/drirc.d/ with name xxx.conf. Config files will be read and applied in file name alphabetic order. So there are three places for drirc listed in order: 1. /usr/share/drirc.d/ 2. /etc/drirc 3. ~/.drirc v4: fix meson build v3: 1. seperate driParseConfigFiles refine into another patch 2. fix entries[i] mem leak v2: drop /etc/drirc.d Signed-off-by: Qiang Yu <[email protected]> Acked-by: Michel Dänzer <[email protected]> Reviewed-by: Emil Velikov <[email protected]>
Diffstat (limited to 'src/util/Makefile.am')
-rw-r--r--src/util/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/util/Makefile.am b/src/util/Makefile.am
index bafb57439ab..8d8c1566e1e 100644
--- a/src/util/Makefile.am
+++ b/src/util/Makefile.am
@@ -67,6 +67,7 @@ libxmlconfig_la_CFLAGS = \
-I$(top_srcdir)/include \
-I$(top_srcdir)/src \
-DSYSCONFDIR=\"$(sysconfdir)\" \
+ -DDATADIR=\"$(datadir)\" \
$(VISIBILITY_CFLAGS) \
$(EXPAT_CFLAGS)
libxmlconfig_la_LIBADD = $(EXPAT_LIBS) -lm