summaryrefslogtreecommitdiffstats
path: root/src/util/Makefile.am
diff options
context:
space:
mode:
authorCarl Worth <[email protected]>2014-12-12 13:55:30 -0800
committerCarl Worth <[email protected]>2015-01-16 13:47:40 -0800
commita24bdce46f95cbe9efd3b26f157d1eb36584861f (patch)
treef5e328a4556593bec7b2a8f0c13bd723c19be7df /src/util/Makefile.am
parent670826b431202fa7cceab9ca86fa21747a1be16c (diff)
mesa: Add mesa SHA-1 functions
The upcoming shader cache uses the SHA-1 algorithm for cryptographic naming. These new mesa_sha1 functions are implemented with any one of several differeny cryptographics libraries. This code was copied from the xserver repository, (where it has apparently been functioning well on a variety of operating systems), and comes licensed with a license identical to that of Mesa. Bug fixes by José Fonseca <[email protected]>: Fix to put conditional assignment in Makefile.am, not Makefile.sources to avoid breaking scons build. Fix include file for CryptoAPI section. Fix missing cast in openssl section. Reviewed-by: Matt Turner <[email protected]>
Diffstat (limited to 'src/util/Makefile.am')
-rw-r--r--src/util/Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/src/util/Makefile.am b/src/util/Makefile.am
index c7e183e8d61..03b619efeb7 100644
--- a/src/util/Makefile.am
+++ b/src/util/Makefile.am
@@ -31,12 +31,19 @@ libmesautil_la_CPPFLAGS = \
-I$(top_srcdir)/src \
-I$(top_srcdir)/src/mapi \
-I$(top_srcdir)/src/mesa \
+ $(SHA1_CFLAGS) \
$(VISIBILITY_CFLAGS)
libmesautil_la_SOURCES = \
$(MESA_UTIL_FILES) \
$(MESA_UTIL_GENERATED_FILES)
+if HAVE_SHA1
+libmesautil_la_SOURCES += $(MESA_UTIL_SHA1_FILES)
+endif
+
+libmesautil_la_LIBADD = $(SHA1_LIBS)
+
check_PROGRAMS = u_atomic_test
TESTS = $(check_PROGRAMS)