summaryrefslogtreecommitdiffstats
path: root/src/panfrost/midgard/meson.build
diff options
context:
space:
mode:
authorAlyssa Rosenzweig <[email protected]>2019-07-10 10:33:24 -0700
committerAlyssa Rosenzweig <[email protected]>2019-07-10 10:43:23 -0700
commitec2a59cd7aa42652645e76e29a72335370c80e50 (patch)
tree08e75a12d073cc627307bc59ab3a8d057244b68e /src/panfrost/midgard/meson.build
parenta2d0ea92ba752c62e59aa681acda7b97fc86d100 (diff)
panfrost: Move non-Gallium files outside of Gallium
In preparation for a Panfrost-based non-Gallium driver (maybe Vulkan...?), hoist everything except for the Gallium driver into a shared src/panfrost. Practically, that means the compilers, the headers, and pandecode. Signed-off-by: Alyssa Rosenzweig <[email protected]>
Diffstat (limited to 'src/panfrost/midgard/meson.build')
-rw-r--r--src/panfrost/midgard/meson.build63
1 files changed, 63 insertions, 0 deletions
diff --git a/src/panfrost/midgard/meson.build b/src/panfrost/midgard/meson.build
new file mode 100644
index 00000000000..cbe26004e2d
--- /dev/null
+++ b/src/panfrost/midgard/meson.build
@@ -0,0 +1,63 @@
+# Copyright © 2018 Rob Clark
+# Copyright © 2019 Collabora
+
+# Permission is hereby granted, free of charge, to any person obtaining a copy
+# of this software and associated documentation files (the "Software"), to deal
+# in the Software without restriction, including without limitation the rights
+# to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+# copies of the Software, and to permit persons to whom the Software is
+# furnished to do so, subject to the following conditions:
+
+# The above copyright notice and this permission notice shall be included in
+# all copies or substantial portions of the Software.
+
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+# AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+# LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+# OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+# SOFTWARE.
+
+libpanfrost_midgard_files = files(
+ 'midgard_compile.c',
+ 'mir.c',
+ 'midgard_print.c',
+ 'midgard_schedule.c',
+ 'midgard_emit.c',
+ 'midgard_ra.c',
+ 'midgard_ra_pipeline.c',
+ 'midgard_liveness.c',
+ 'midgard_ops.c',
+ 'cppwrap.cpp',
+ 'disassemble.c',
+)
+
+midgard_nir_algebraic_c = custom_target(
+ 'midgard_nir_algebraic.c',
+ input : 'midgard_nir_algebraic.py',
+ output : 'midgard_nir_algebraic.c',
+ command : [
+ prog_python, '@INPUT@',
+ '-p', join_paths(meson.source_root(), 'src/compiler/nir/'),
+ ],
+ capture : true,
+ depend_files : nir_algebraic_py,
+)
+
+libpanfrost_midgard = static_library(
+ 'panfrost_midgard',
+ [libpanfrost_midgard_files, midgard_nir_algebraic_c],
+ include_directories : [
+ inc_common,
+ inc_include,
+ inc_src,
+ inc_panfrost_hw,
+ ],
+ dependencies: [
+ idep_nir
+ ],
+ c_args : [c_vis_args, no_override_init_args],
+ cpp_args : [cpp_vis_args],
+ build_by_default : false,
+)