summaryrefslogtreecommitdiffstats
path: root/src/panfrost/meson.build
diff options
context:
space:
mode:
authorAlyssa Rosenzweig <[email protected]>2020-04-01 14:40:33 -0400
committerMarge Bot <[email protected]>2020-04-05 23:26:04 +0000
commit14c534386742b44bc02349684b0a0e3972fec91d (patch)
treec070d8905592f66b346877ea916f1ac8a7249b91 /src/panfrost/meson.build
parent5e3e32e368caabc50b669967b1a81b0f32102194 (diff)
pan/bit: Add packing test framework
Given an instruction, we'd like to wrap it in a clause with some I/O on each end so we can pack it up and send it to the hardware to compare against the simulator. Signed-off-by: Alyssa Rosenzweig <[email protected]> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/4458>
Diffstat (limited to 'src/panfrost/meson.build')
-rw-r--r--src/panfrost/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/panfrost/meson.build b/src/panfrost/meson.build
index eb2fb932f4f..68442fd3790 100644
--- a/src/panfrost/meson.build
+++ b/src/panfrost/meson.build
@@ -38,6 +38,7 @@ files_bifrost = files(
'bifrost/cmdline.c',
'bifrost/test/bi_submit.c',
'bifrost/test/bi_interpret.c',
+ 'bifrost/test/bi_test_pack.c',
)
bifrost_compiler = executable(