summaryrefslogtreecommitdiffstats
path: root/src/panfrost/meson.build
diff options
context:
space:
mode:
authorAlyssa Rosenzweig <[email protected]>2019-07-10 10:33:24 -0700
committerAlyssa Rosenzweig <[email protected]>2019-07-10 10:43:23 -0700
commitec2a59cd7aa42652645e76e29a72335370c80e50 (patch)
tree08e75a12d073cc627307bc59ab3a8d057244b68e /src/panfrost/meson.build
parenta2d0ea92ba752c62e59aa681acda7b97fc86d100 (diff)
panfrost: Move non-Gallium files outside of Gallium
In preparation for a Panfrost-based non-Gallium driver (maybe Vulkan...?), hoist everything except for the Gallium driver into a shared src/panfrost. Practically, that means the compilers, the headers, and pandecode. Signed-off-by: Alyssa Rosenzweig <[email protected]>
Diffstat (limited to 'src/panfrost/meson.build')
-rw-r--r--src/panfrost/meson.build60
1 files changed, 59 insertions, 1 deletions
diff --git a/src/panfrost/meson.build b/src/panfrost/meson.build
index 6b167d04b9c..9c12ff8fd8e 100644
--- a/src/panfrost/meson.build
+++ b/src/panfrost/meson.build
@@ -19,6 +19,64 @@
# OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
# SOFTWARE.
-inc_panfrost = include_directories(['.', 'shared'])
+inc_panfrost_hw = include_directories([
+ 'include'
+])
+
+inc_panfrost = include_directories([
+ '.', 'include', 'shared', 'midgard', 'bifrost'
+])
subdir('shared')
+subdir('midgard')
+subdir('bifrost')
+subdir('pandecode')
+
+files_pandecode = files(
+ 'pandecode/cmdline.c',
+ 'pandecode/common.c',
+ 'pandecode/decode.c',
+ 'pandecode/pan_pretty_print.c',
+
+ 'midgard/disassemble.c',
+ 'midgard/midgard_ops.c',
+ 'bifrost/disassemble.c',
+)
+
+pandecode = executable(
+ 'pandecoder',
+ files_pandecode,
+ include_directories : [inc_common, inc_include, inc_src, inc_panfrost],
+ dependencies : [
+ dep_thread,
+ ],
+ link_with : [
+ libmesa_util
+ ],
+ build_by_default : true
+)
+
+files_bifrost = files(
+ 'bifrost/cmdline.c',
+)
+
+bifrost_compiler = executable(
+ 'bifrost_compiler',
+ [files_bifrost],
+ include_directories : [
+ inc_common,
+ inc_include,
+ inc_src,
+ inc_panfrost,
+ ],
+ dependencies : [
+ dep_thread,
+ idep_nir
+ ],
+ link_with : [
+ libglsl_standalone,
+ libmesa_util,
+ libpanfrost_bifrost
+ ],
+ build_by_default : true
+)