aboutsummaryrefslogtreecommitdiffstats
path: root/src/meson.build
diff options
context:
space:
mode:
authorDylan Baker <[email protected]>2018-02-26 08:43:54 -0800
committerDylan Baker <[email protected]>2018-02-26 09:32:14 -0800
commitb9636fe38aea6af1d3a30528da89069fc390b6a0 (patch)
treed0082d0e4cbf8a2b8d9d436ce4cb0e14059b0181 /src/meson.build
parentfca9f5b5851d2eeba6d030e28dd783017fef55cf (diff)
meson: fix building without GL
libgl will be undefined _glx, so move that check inside the `if with_glx != 'disabled'` block. v2: - Simplify commit message (Eric, Emil) Fixes: 5c460337fd9c109 ("meson: Fix GL and EGL pkg-config files with glvnd") Reported-by: Jason Ekstrand <[email protected]> Signed-off-by: Dylan Baker <[email protected]> CC: Daniel Stone <[email protected]> Acked-by: Jason Ekstrand <[email protected]> Untested-by: Jason Ekstrand <[email protected]> Acked-by: Eric Engestrom <[email protected]> Reviewed-by: Emil Velikov <[email protected]>
Diffstat (limited to 'src/meson.build')
-rw-r--r--src/meson.build19
1 files changed, 10 insertions, 9 deletions
diff --git a/src/meson.build b/src/meson.build
index b2c045fce10..19005271d73 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -82,18 +82,19 @@ if with_gallium
subdir('gallium')
endif
-# If using glvnd the pkg-config header should not point to GL_mesa, it should
-# point to GL. glvnd is only available on unix like platforms so adding -l
-# should be safe here
-# TODO: in the glvnd case glvnd itself should really be providing this.
-if with_glvnd
- _gl = '-L${libdir} -lGL'
-else
- _gl = libgl
-endif
# This must be after at least mesa, glx, and gallium, since libgl will be
# defined in one of those subdirs depending on the glx provider.
if with_glx != 'disabled'
+ # If using glvnd the pkg-config header should not point to GL_mesa, it should
+ # point to GL. glvnd is only available on unix like platforms so adding -l
+ # should be safe here
+ # TODO: in the glvnd case glvnd itself should really be providing this.
+ if with_glvnd
+ _gl = '-L${libdir} -lGL'
+ else
+ _gl = libgl
+ endif
+
pkg.generate(
name : 'gl',
description : 'Mesa OpenGL Library',