aboutsummaryrefslogtreecommitdiffstats
path: root/src/meson.build
diff options
context:
space:
mode:
authorEric Engestrom <[email protected]>2019-09-18 21:48:49 +0100
committerEric Engestrom <[email protected]>2019-09-18 22:16:51 +0100
commita1de3011f380b6ffd5583708b58e3f86d8d45ea9 (patch)
tree25d11db98b7f3618f91cc4ad2d63350c2f70b14b /src/meson.build
parent66f2aa6ccd0b226eebe2c1a46281160b0a54d522 (diff)
gl: drop incorrect pkg-config file for glvnd
Akin to 1a25980c469b38d2c645 ("egl: drop incorrect pkg-config file for glvnd") and b01524fff05eef66e8cd ("meson: don't build libGLES*.so with GLVND") , removes a pkg-config file that shouldn't have been there in the first place, but was needed because of that GLVND bug. Now that the glvnd bug has been fixed, it was apparent that this gl.pc pkg-config file was forgotten to be removed, so let's do just that :) Suggested-by: Matt Turner <[email protected]> Cc: [email protected] Signed-off-by: Eric Engestrom <[email protected]> Reviewed-by: Matt Turner <[email protected]>
Diffstat (limited to 'src/meson.build')
-rw-r--r--src/meson.build14
1 files changed, 2 insertions, 12 deletions
diff --git a/src/meson.build b/src/meson.build
index 71ff82af38f..11e0011c057 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -111,22 +111,12 @@ endif
# This must be after at least mesa, glx, and gallium, since libgl will be
# defined in one of those subdirs depending on the glx provider.
-if with_glx != 'disabled'
- # If using glvnd the pkg-config header should not point to GL_mesa, it should
- # point to GL. glvnd is only available on unix like platforms so adding -l
- # should be safe here
- # TODO: in the glvnd case glvnd itself should really be providing this.
- if with_glvnd
- _gl = '-L${libdir} -lGL'
- else
- _gl = libgl
- endif
-
+if with_glx != 'disabled' and not with_glvnd
pkg.generate(
name : 'gl',
description : 'Mesa OpenGL Library',
version : meson.project_version(),
- libraries : _gl,
+ libraries : libgl,
libraries_private : gl_priv_libs,
requires_private : gl_priv_reqs,
variables : ['glx_tls=yes'],