aboutsummaryrefslogtreecommitdiffstats
path: root/src/meson.build
diff options
context:
space:
mode:
authorDylan Baker <[email protected]>2017-09-28 15:53:53 -0700
committerDylan Baker <[email protected]>2017-10-09 13:42:44 -0700
commit816bf7d1644b9b14df253c5d54f595514aa34703 (patch)
treeb87d9a8bc916c8e81744b1440490074a398b050a /src/meson.build
parentdb9788420d4bc7b4a61eab38c0093af94274d00d (diff)
meson: build gbm
This doesn't include egl support, just dri support. v2: - when gbm is set to 'auto', only build if a dri driver is also enabled - Fix conditional to check for x11 modules with vulkan as well as with dri drivers v3: - Set pkgconfig libraries.private value Signed-off-by: Dylan Baker <[email protected]> Reviewed-by: Eric Anholt <[email protected]>
Diffstat (limited to 'src/meson.build')
-rw-r--r--src/meson.build4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/meson.build b/src/meson.build
index f49ad9e0e7e..544d831ea63 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -54,6 +54,8 @@ subdir('intel')
subdir('mesa')
subdir('loader')
subdir('glx')
-# TODO: dri_glx
+if with_gbm
+ subdir('gbm')
+endif
# TODO: egl
# TODO: gallium