aboutsummaryrefslogtreecommitdiffstats
path: root/src/meson.build
diff options
context:
space:
mode:
authorEric Engestrom <[email protected]>2019-09-25 17:38:49 +0100
committerEric Engestrom <[email protected]>2019-10-31 17:09:59 +0000
commit6e21dcc5a31634232660eff1a83052c2ebb4816c (patch)
tree0061d60279b43c9ed33929e31e115aef789e0093 /src/meson.build
parent0f201e9dbc8711f61a692de50cf283a30fad3030 (diff)
meson: revert glvnd workaround
This effectively reverts MR !2112. Signed-off-by: Eric Engestrom <[email protected]> Reviewed-by: Dylan Baker <[email protected]>
Diffstat (limited to 'src/meson.build')
-rw-r--r--src/meson.build14
1 files changed, 2 insertions, 12 deletions
diff --git a/src/meson.build b/src/meson.build
index 15fa52be57c..cefa1c9ac28 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -112,22 +112,12 @@ endif
# This must be after at least mesa, glx, and gallium, since libgl will be
# defined in one of those subdirs depending on the glx provider.
-if with_glx != 'disabled' and (not with_glvnd or not glvnd_has_headers_and_pc_files)
- # If using glvnd the pkg-config header should not point to GL_mesa, it should
- # point to GL. glvnd is only available on unix like platforms so adding -l
- # should be safe here
- # TODO: in the glvnd case glvnd itself should really be providing this.
- if not glvnd_has_headers_and_pc_files
- _gl = '-L${libdir} -lGL'
- else
- _gl = libgl
- endif
-
+if with_glx != 'disabled' and not with_glvnd
pkg.generate(
name : 'gl',
description : 'Mesa OpenGL Library',
version : meson.project_version(),
- libraries : _gl,
+ libraries : libgl,
libraries_private : gl_priv_libs,
requires_private : gl_priv_reqs,
variables : ['glx_tls=yes'],