aboutsummaryrefslogtreecommitdiffstats
path: root/src/meson.build
diff options
context:
space:
mode:
authorTimur Kristóf <[email protected]>2019-09-27 10:29:51 +0200
committerBas Nieuwenhuizen <[email protected]>2019-10-08 00:44:08 +0000
commit3a08110d43ce268747d034cae03787080967bf71 (patch)
treeee02037354a4a3846f9cb75df486b036345a5acc /src/meson.build
parent738bbee603fd3fd8ea29edab7b681e48bc981467 (diff)
amd: Move all amd/common code that depends on LLVM to amd/llvm.
This commit is a step towards the goal of being able to build RADV without LLVM. In the future we would like to offer the option to use RADV solely with ACO. There is still a need for the common AMD code located in amd/common but the LLVM specific parts need to be separated. Signed-off-by: Timur Kristóf <[email protected]> Reviewed-by: Bas Nieuwenhuizen <[email protected]> Acked-by: Marek Olšák <[email protected]> Acked-by: Samuel Pitoiset <[email protected]>
Diffstat (limited to 'src/meson.build')
-rw-r--r--src/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/meson.build b/src/meson.build
index d01f84c0d46..10b2772f907 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -26,6 +26,7 @@ inc_src = include_directories('.')
inc_gallium = include_directories('gallium/include')
inc_gallium_aux = include_directories('gallium/auxiliary')
inc_amd_common = include_directories('amd/common')
+inc_amd_common_llvm = include_directories('amd/llvm')
libglsl_util = static_library(
'glsl_util',