aboutsummaryrefslogtreecommitdiffstats
path: root/src/meson.build
diff options
context:
space:
mode:
authorEric Engestrom <[email protected]>2018-10-11 16:21:14 +0100
committerEric Engestrom <[email protected]>2018-11-13 17:25:02 +0000
commit3832db275efdb235b3b7b27c9b41e64d5507aa2c (patch)
tree8be787cb582909ff657a8d62b5f065bde5c0ad5a /src/meson.build
parent4f1ae271e11a60603638c17d75086bbe02a66eb3 (diff)
meson: only run vulkan's meson.build when building vulkan
Fixes: d1992255bb29054fa5176 "meson: Add build Intel "anv" vulkan driver" Signed-off-by: Eric Engestrom <[email protected]> Reviewed-by: Emil Velikov <[email protected]> Reviewed-by: Dylan Baker <[email protected]>
Diffstat (limited to 'src/meson.build')
-rw-r--r--src/meson.build4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/meson.build b/src/meson.build
index 73146d37143..2c0bff73432 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -52,7 +52,9 @@ subdir('mapi')
# TODO: opengl
subdir('compiler')
subdir('egl/wayland/wayland-drm')
-subdir('vulkan')
+if with_any_vk
+ subdir('vulkan')
+endif
if with_gallium_radeonsi or with_amd_vk
subdir('amd')
endif