summaryrefslogtreecommitdiffstats
path: root/src/meson.build
diff options
context:
space:
mode:
authorEmil Velikov <[email protected]>2018-12-12 17:47:36 +0000
committerEmil Velikov <[email protected]>2018-12-12 17:47:36 +0000
commit9527f9ea2611b0793377016c8c16ec58ded7f287 (patch)
tree7b50273f347672a5a9902ecf4c1a16932cc2707b /src/meson.build
parent2eedb79e1a2e92648bd245f9db88ecb7b587b7fd (diff)
TODO: glx: meson: build dri based glx tests, only with -Dglx=dri
The library itself (libGL) is only built when -Dglx=dri, yet it's accompanying tests are build even with -Dglx=xlib. Adjust the guards, so we don't build the tests when they are not applicable v2: - Reword commit message (Dylan) - Drop build_by_default hunk (Dylan) Fixes: a47c525f328 ("meson: build glx") Signed-off-by: Emil Velikov <[email protected]> Reviewed-by: Dylan Baker <[email protected]>
Diffstat (limited to 'src/meson.build')
-rw-r--r--src/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/meson.build b/src/meson.build
index 915441fb2ce..ae094fccf6c 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -74,7 +74,7 @@ subdir('loader')
if with_platform_haiku
subdir('hgl')
endif
-if with_glx != 'disabled'
+if with_glx == 'dri'
subdir('glx')
endif
if with_gbm