summaryrefslogtreecommitdiffstats
path: root/src/meson.build
diff options
context:
space:
mode:
authorEric Anholt <[email protected]>2018-09-25 19:15:45 -0700
committerEric Anholt <[email protected]>2019-07-25 08:56:19 -0700
commit82bf1979d7b7d83e8e213b11ff7787e6939c8f7e (patch)
tree595ad86905bae25e153d1c7a82041eedef0f20f7 /src/meson.build
parentc5f14322965cc006038e293902412e76ad268767 (diff)
v3d: Introduce a DRM shim for calling out to the simulator.
The goal is to enable testing of parts of drivers without depending on any particular kernel version or hardware being present. Simply set LD_PRELOAD=$PREFIX/lib/libv3d_drm_shim.so in your environment, and we'll fake a /dev/dri/renderD128 (or whatever the next available node is) using v3dv3. That node can then be used with the surfaceless or gbm EGL platforms. Acked-by: Iago Toral Quiroga <[email protected]>
Diffstat (limited to 'src/meson.build')
-rw-r--r--src/meson.build3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/meson.build b/src/meson.build
index 0dcd7eef65d..d86c0ec21a6 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -51,6 +51,9 @@ subdir('util')
subdir('mapi')
# TODO: opengl
subdir('compiler')
+if with_tools.contains('drm-shim')
+ subdir('drm-shim')
+endif
subdir('imgui')
if with_platform_wayland
subdir('egl/wayland/wayland-drm')