summaryrefslogtreecommitdiffstats
path: root/src/meson.build
diff options
context:
space:
mode:
authorEric Engestrom <[email protected]>2019-09-30 10:26:43 +0100
committerEric Engestrom <[email protected]>2019-10-10 22:18:04 +0100
commitb57fa7ca49f7ddb67ac47f392de05af388e73565 (patch)
tree911dd098afaeeede5b7c0dfa958268a1e8ae6380 /src/meson.build
parenta0829cf23b307ca44ab8c4505974fb7c8d71a35a (diff)
meson: rename `glvnd_missing_pc_files` to `not glvnd_has_headers_and_pc_files`
This reflects better what is provided by glvnd or not. Fixes: 93df862b6affb6b8507e ("meson: re-add incorrect pkg-config files with GLVND for backward compatibility") Signed-off-by: Eric Engestrom <[email protected]> Reviewed-by: Dylan Baker <[email protected]>
Diffstat (limited to 'src/meson.build')
-rw-r--r--src/meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/meson.build b/src/meson.build
index 10b2772f907..15fa52be57c 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -112,12 +112,12 @@ endif
# This must be after at least mesa, glx, and gallium, since libgl will be
# defined in one of those subdirs depending on the glx provider.
-if with_glx != 'disabled' and (not with_glvnd or glvnd_missing_pc_files)
+if with_glx != 'disabled' and (not with_glvnd or not glvnd_has_headers_and_pc_files)
# If using glvnd the pkg-config header should not point to GL_mesa, it should
# point to GL. glvnd is only available on unix like platforms so adding -l
# should be safe here
# TODO: in the glvnd case glvnd itself should really be providing this.
- if glvnd_missing_pc_files
+ if not glvnd_has_headers_and_pc_files
_gl = '-L${libdir} -lGL'
else
_gl = libgl