summaryrefslogtreecommitdiffstats
path: root/src/meson.build
diff options
context:
space:
mode:
authorEric Engestrom <[email protected]>2017-10-24 18:03:39 +0100
committerEric Engestrom <[email protected]>2017-10-27 13:38:37 +0100
commit05a94a4dfc79f95d597dd6fc08eea4a947eb300c (patch)
tree87edb77470fea174b4c20b84e72cda29dea9438b /src/meson.build
parent7088622e5fb506b64c906b673a9af0feb9a5ba14 (diff)
meson: bring MESA_GIT_SHA1 in line with other build systems
Meson's vcs_tag() uses the output of `git describe`, eg. 17.3-branchpoint-5-gfbf29c3cd15ae831e249+ Whereas the other build systems used a script that outputs only the sha1 of the HEAD commit, eg. fbf29c3cd1 Given that this information is used by printing it next to the version number, there's some redundancy here, and inconsistency between build systems. Bring Meson in line by making it use the same script, with the added advantage of now supporting the MESA_GIT_SHA1_OVERRIDE env var. Signed-off-by: Eric Engestrom <[email protected]> Reviewed-by: Jordan Justen <[email protected]> Reviewed-by: Dylan Baker <[email protected]>
Diffstat (limited to 'src/meson.build')
-rw-r--r--src/meson.build6
1 files changed, 4 insertions, 2 deletions
diff --git a/src/meson.build b/src/meson.build
index 9b1b0ae594d..f980d25b7dd 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -34,9 +34,11 @@ libglsl_util = static_library(
build_by_default : false,
)
-sha1_h = vcs_tag(
- input : 'git_sha1.h.in',
+sha1_h = custom_target(
+ 'git_sha1.h',
output : 'git_sha1.h',
+ command : [prog_python2, git_sha1_gen_py, '--output', '@OUTPUT@'],
+ build_always : true, # commit sha1 can change without having touched these files
)
subdir('gtest')