summaryrefslogtreecommitdiffstats
path: root/src/meson.build
diff options
context:
space:
mode:
authorDylan Baker <[email protected]>2017-11-14 17:03:39 -0800
committerDylan Baker <[email protected]>2017-11-20 14:28:31 -0800
commit689fb7471671991b3971eeb4f0fa8aa3721c4822 (patch)
tree83ff26e34680cd03b17c90db49daf0a24c3c086c /src/meson.build
parent494effd242d9311f5ff1c923d55322970e4296bc (diff)
meson: don't build gallium subdir unless we're building gallium
This will allow us to simplify some guards within the gallium directory. Signed-off-by: Dylan Baker <[email protected]> Reviewed-by: Eric Anholt <[email protected]>
Diffstat (limited to 'src/meson.build')
-rw-r--r--src/meson.build4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/meson.build b/src/meson.build
index 9232cc4ab18..00bbaa8989c 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -69,7 +69,9 @@ endif
if with_egl
subdir('egl')
endif
-subdir('gallium')
+if with_gallium
+ subdir('gallium')
+endif
# This must be after at least mesa, glx, and gallium, since libgl will be
# defined in one of those subdirs depending on the glx provider.