aboutsummaryrefslogtreecommitdiffstats
path: root/src/mesa/meson.build
diff options
context:
space:
mode:
authorDylan Baker <[email protected]>2017-11-15 16:09:22 -0800
committerDylan Baker <[email protected]>2017-11-22 12:46:00 -0800
commit84486f64626ad2b51291b84965d1bc96f68d8127 (patch)
tree0f1c7ca332c750a11db9cb713dd621aed2fa4583 /src/mesa/meson.build
parent6a78416dabdf0b7b80471dd0c636164c8f4012e0 (diff)
meson: Enable SSE4.1 optimizations
This patch checks for an and then enables sse4.1 optimizations if the host machine will be x86/x86_64. v2: - Don't compile code, it's unnecessary since we require a compiler which always has SSE4.1 (Matt) v3: - x64 -> x86_64 (Matt) Signed-off-by: Dylan Baker <[email protected]> Reviewed-by: Eric Engestrom <[email protected]>
Diffstat (limited to 'src/mesa/meson.build')
-rw-r--r--src/mesa/meson.build14
1 files changed, 11 insertions, 3 deletions
diff --git a/src/mesa/meson.build b/src/mesa/meson.build
index b839fd02981..05a3a9ac55d 100644
--- a/src/mesa/meson.build
+++ b/src/mesa/meson.build
@@ -592,9 +592,6 @@ files_libmesa_gallium = files(
'state_tracker/st_vdpau.h',
)
-# TODO: sse41
-libmesa_sse41 = []
-
matypes_h = []
if with_asm_arch == 'x86' or with_asm_arch == 'x86_64'
gen_matypes = executable(
@@ -692,6 +689,17 @@ files_libmesa_common += [
sha1_h,
]
+if with_sse41
+ libmesa_sse41 = static_library(
+ 'mesa_sse41',
+ files('main/streaming-load-memcpy.c', 'main/sse_minmax.c'),
+ c_args : [c_vis_args, c_msvc_compat_args, sse41_args],
+ include_directories : inc_common,
+ )
+else
+ libmesa_sse41 = []
+endif
+
libmesa_classic = static_library(
'mesa_classic',
[files_libmesa_common, files_libmesa_classic],