summaryrefslogtreecommitdiffstats
path: root/src/mesa/meson.build
diff options
context:
space:
mode:
authorJordan Justen <[email protected]>2017-11-04 16:52:14 -0700
committerTimothy Arceri <[email protected]>2017-12-08 16:59:25 +1100
commitc20fd744fef1ffb938f74dbafbe375c863fecc65 (patch)
tree062bbbeeee93738a7bd51821a7dc3dbdc8b78534 /src/mesa/meson.build
parent90d4abdd872b62943b33d62c9368fe7855b1c4fc (diff)
mesa: Add Mesa ARB_get_program_binary helper functions
V2 (Timothy Arceri): - add extra code comment - stop passing around void *binary and just pass program_binary_header *hdr instead. - move to src/mesa/main rather than src/util V3 (Timothy Arceri): - Move more code out of the backend and into the common helpers. Signed-off-by: Jordan Justen <[email protected]> Reviewed-by: Tapani Pälli <[email protected]>
Diffstat (limited to 'src/mesa/meson.build')
-rw-r--r--src/mesa/meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/mesa/meson.build b/src/mesa/meson.build
index 05a3a9ac55d..670c3d22d24 100644
--- a/src/mesa/meson.build
+++ b/src/mesa/meson.build
@@ -215,6 +215,8 @@ files_libmesa_common = files(
'main/points.h',
'main/polygon.c',
'main/polygon.h',
+ 'main/program_binary.c',
+ 'main/program_binary.h',
'main/program_resource.c',
'main/program_resource.h',
'main/querymatrix.c',