summaryrefslogtreecommitdiffstats
path: root/src/mesa/meson.build
diff options
context:
space:
mode:
authorDylan Baker <[email protected]>2018-04-18 10:53:27 -0700
committerDylan Baker <[email protected]>2018-04-24 14:08:15 -0700
commitaaab6242456a4a5e737da0add179704b0b6f3676 (patch)
treea2f93a41bb2207d4b9589ade11dad81f64a6ae28 /src/mesa/meson.build
parent0e8b16e0a239cc4a4758b62fb6787158180a74fd (diff)
meson: don't build classic mesa tests without dri_drivers
Since mesa_classic is build-on-demand the tests will create a demand and add a bunch of extra compilation. Fixes: 43a6e84927e3b1290f6f211f5dfb184dfe5a719e ("meson: build mesa test.") Signed-off-by: Dylan Baker <[email protected]> Reviewed-by: Eric Anholt <[email protected]>
Diffstat (limited to 'src/mesa/meson.build')
-rw-r--r--src/mesa/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/mesa/meson.build b/src/mesa/meson.build
index c1334c96374..72d87178aa1 100644
--- a/src/mesa/meson.build
+++ b/src/mesa/meson.build
@@ -732,6 +732,6 @@ endif
if with_glx == 'xlib'
subdir('drivers/x11')
endif
-if with_tests
+if with_tests and dri_drivers != []
subdir('main/tests')
endif