summaryrefslogtreecommitdiffstats
path: root/src/mesa/meson.build
diff options
context:
space:
mode:
authorTimothy Arceri <[email protected]>2018-03-09 11:57:52 +1100
committerTimothy Arceri <[email protected]>2018-03-20 14:17:34 +1100
commitffa4bbe4665f95bab7779ded57d6a4de13cb8ffc (patch)
treed00e587b2baccb7cf4da3423baa43835b177a872 /src/mesa/meson.build
parenta80cf442d939212da40951a0a57a0978de6f39a6 (diff)
st/nir/radeonsi: move nir_lower_uniforms_to_ubo() to the state tracker
This will only ever be used by gallium drivers so it probably doesn't belong in the nir toolkit. Also we want to pass it some non NIR things in the following patch. To avoid regressions we wrap the lowering calls that have been moved to st_glsl_to_nir with a quick hack so that they are only called for radeonsi, we will replace the hack with a check for uniform packing in a following patch. Reviewed-by: Marek Olšák <[email protected]>
Diffstat (limited to 'src/mesa/meson.build')
-rw-r--r--src/mesa/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/mesa/meson.build b/src/mesa/meson.build
index aa27d592641..b74d1693771 100644
--- a/src/mesa/meson.build
+++ b/src/mesa/meson.build
@@ -579,6 +579,7 @@ files_libmesa_gallium = files(
'state_tracker/st_nir.h',
'state_tracker/st_nir_lower_builtin.c',
'state_tracker/st_nir_lower_tex_src_plane.c',
+ 'state_tracker/st_nir_lower_uniforms_to_ubo.c',
'state_tracker/st_pbo.c',
'state_tracker/st_pbo.h',
'state_tracker/st_program.c',