summaryrefslogtreecommitdiffstats
path: root/src/mesa/meson.build
diff options
context:
space:
mode:
authorGert Wollny <[email protected]>2018-06-05 22:26:39 +0200
committerGert Wollny <[email protected]>2018-08-11 12:32:42 +0200
commitd54c2f92f93a811a853a7b8e87f016ccada04a91 (patch)
treed132659317b67a238a32b90c49a9102b4cccc6bf /src/mesa/meson.build
parent331ae3cde5fd6689cd00112fd365da0d00dc5e56 (diff)
mesa/st/glsl_to_tgsi: Add helper class for array live range merging and interleaving
This class holds the array length, live range, and accessed components, and it implements the logic for evaluating how arrays are merged and interleaved. v4: - Add logic to evaluate merge and interleave of a pair of arrays to the class array_live_range. - document class - update commit message Thanks Nicolai Hähnle for the pointers given. Signed-off-by: Gert Wollny <[email protected]> Acked-by: Dave Airlie <[email protected]>
Diffstat (limited to 'src/mesa/meson.build')
-rw-r--r--src/mesa/meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/mesa/meson.build b/src/mesa/meson.build
index 10ae63b611b..ea884977db8 100644
--- a/src/mesa/meson.build
+++ b/src/mesa/meson.build
@@ -568,6 +568,8 @@ files_libmesa_gallium = files(
'state_tracker/st_glsl_to_nir.cpp',
'state_tracker/st_glsl_to_tgsi.cpp',
'state_tracker/st_glsl_to_tgsi.h',
+ 'state_tracker/st_glsl_to_tgsi_array_merge.cpp',
+ 'state_tracker/st_glsl_to_tgsi_array_merge.h',
'state_tracker/st_glsl_to_tgsi_private.cpp',
'state_tracker/st_glsl_to_tgsi_private.h',
'state_tracker/st_glsl_to_tgsi_temprename.cpp',