summaryrefslogtreecommitdiffstats
path: root/src/mesa/meson.build
diff options
context:
space:
mode:
authorDylan Baker <[email protected]>2017-10-20 21:48:18 -0700
committerDylan Baker <[email protected]>2017-10-27 11:06:45 -0700
commitcbbd5bb889a2c271a504c379f36a7cb717a85af4 (patch)
tree58c7208233c088bdca901498a2ab3ed704469225 /src/mesa/meson.build
parent7503ab687b3992b0967eafd4fb7372ddb3f4445a (diff)
meson: build classic osmesa
This builds the classic (non-gallium) osmesa with meson. This has been tested with the osdemo application from mesa-demos. v2: - Remove unrelated change - Add SELinux dependency to osmesa Signed-off-by: Dylan Baker <[email protected]> Reviewed-by: Eric Engestrom <[email protected]>
Diffstat (limited to 'src/mesa/meson.build')
-rw-r--r--src/mesa/meson.build3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/mesa/meson.build b/src/mesa/meson.build
index 846a40da822..20d06aad4dd 100644
--- a/src/mesa/meson.build
+++ b/src/mesa/meson.build
@@ -718,6 +718,9 @@ libmesa_gallium = static_library(
)
subdir('drivers/dri')
+if with_osmesa == 'classic'
+ subdir('drivers/osmesa')
+endif
if with_tests
subdir('main/tests')
endif