summaryrefslogtreecommitdiffstats
path: root/src/mesa/meson.build
diff options
context:
space:
mode:
authorMathieu Bridon <[email protected]>2018-08-09 10:27:26 +0200
committerDylan Baker <[email protected]>2018-08-10 15:15:09 -0700
commit2ee1c86d71bee5ddca2c8795b4d343e31d28df99 (patch)
tree434ff307fe52734f62ae83427accc863cb455778 /src/mesa/meson.build
parentbd27203f4d808763ac24ac94eb677cacf3e7cb99 (diff)
meson: Build with Python 3
Now that all the build scripts are compatible with both Python 2 and 3, we can flip the switch and tell Meson to use the latter. Since Meson already depends on Python 3 anyway, this means we don't need two different Python stacks to build Mesa. Signed-off-by: Mathieu Bridon <[email protected]> Reviewed-by: Eric Engestrom <[email protected]> Reviewed-by: Dylan Baker <[email protected]>
Diffstat (limited to 'src/mesa/meson.build')
-rw-r--r--src/mesa/meson.build6
1 files changed, 3 insertions, 3 deletions
diff --git a/src/mesa/meson.build b/src/mesa/meson.build
index 29633691ee7..10ae63b611b 100644
--- a/src/mesa/meson.build
+++ b/src/mesa/meson.build
@@ -664,7 +664,7 @@ format_fallback_c = custom_target(
'format_fallback.c',
input : ['main/format_fallback.py', 'main/formats.csv'],
output : 'format_fallback.c',
- command : [prog_python2, '@INPUT0@', '@INPUT1@', '@OUTPUT@'],
+ command : [prog_python, '@INPUT0@', '@INPUT1@', '@OUTPUT@'],
depend_files : files('main/format_parser.py'),
)
@@ -672,7 +672,7 @@ get_hash_h = custom_target(
'get_hash.h',
input : ['main/get_hash_generator.py', gl_and_es_api_files],
output : 'get_hash.h',
- command : [prog_python2, '@INPUT0@', '-f', '@INPUT1@'],
+ command : [prog_python, '@INPUT0@', '-f', '@INPUT1@'],
depend_files : files('main/get_hash_params.py'),
capture : true,
)
@@ -684,7 +684,7 @@ foreach x : [['format_info.h', 'format_info.py'],
x[0],
input : ['main/@0@'.format(x[1]), 'main/formats.csv'],
output : x[0],
- command : [prog_python2, '@INPUT0@', '@INPUT1@'],
+ command : [prog_python, '@INPUT0@', '@INPUT1@'],
depend_files : files('main/format_parser.py'),
capture : true,
)