summaryrefslogtreecommitdiffstats
path: root/src/mesa/meson.build
diff options
context:
space:
mode:
authorDylan Baker <[email protected]>2017-12-12 12:22:56 -0800
committerDylan Baker <[email protected]>2018-01-11 15:40:02 -0800
commit2083a14179eb04d22feebc5751a1a145828d07cf (patch)
tree0fa3d2d540621d00faa6daf0c132aa5127f2dab0 /src/mesa/meson.build
parent60856a7b4982aaaa4f22a002878d5d78cd63e272 (diff)
meson: Use dependencies for nir
This creates two new internal dependencies, idep_nir_headers and idep_nir. The former encapsulates the generation of nir_opcodes.h and nir_builder_opcodes.h and adding src/compiler/nir as an include path. This ensures that any target that needs nir headers will have the includes and that the generated headers will be generated before the target is build. The second, idep_nir, includes the first and additionally links to libnir. This is intended to make it easier to avoid race conditions in the build when using nir, since the number of consumers for libnir and it's headers are quite high. Acked-by: Eric Engestrom <[email protected]> Signed-off-by: Dylan Baker <[email protected]>
Diffstat (limited to 'src/mesa/meson.build')
-rw-r--r--src/mesa/meson.build3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/mesa/meson.build b/src/mesa/meson.build
index ab6bc273129..998953d6411 100644
--- a/src/mesa/meson.build
+++ b/src/mesa/meson.build
@@ -687,7 +687,6 @@ files_libmesa_common += [
main_marshal_generated_h,
main_dispatch_h,
ir_expression_operation_h,
- nir_opcodes_h,
main_remap_helper_h,
matypes_h,
sha1_h,
@@ -711,6 +710,7 @@ libmesa_classic = static_library(
cpp_args : [cpp_vis_args, cpp_msvc_compat_args],
include_directories : [inc_common, include_directories('main')],
link_with : [libglsl, libmesa_sse41],
+ dependencies : idep_nir_headers,
build_by_default : false,
)
@@ -721,6 +721,7 @@ libmesa_gallium = static_library(
cpp_args : [cpp_vis_args, cpp_msvc_compat_args],
include_directories : [inc_common, include_directories('main')],
link_with : [libglsl, libmesa_sse41],
+ dependencies : idep_nir_headers,
build_by_default : false,
)