summaryrefslogtreecommitdiffstats
path: root/src/mesa/meson.build
diff options
context:
space:
mode:
authorDylan Baker <[email protected]>2017-11-01 17:42:41 -0700
committerDylan Baker <[email protected]>2017-11-10 13:00:01 -0800
commit118a7f044191d4ab15ac99f7748a6d6d97e683d1 (patch)
treefa09570d23e5a2c828dda63b710c1e4636ee48c9 /src/mesa/meson.build
parent13752af4edcbebabf20c031a4dc441a5bf7456f4 (diff)
meson: add support for xlib glx
There is a bunch of churn in the main meson.build so that we can correctly set the auto tristate of GLX. In particular, don't build xlib-based glx when dri and gallium are disabled but vulkan is enabled, in that case just turn glx off. Signed-off-by: Dylan Baker <[email protected]> Reviewed-by: Eric Anholt <[email protected]>
Diffstat (limited to 'src/mesa/meson.build')
-rw-r--r--src/mesa/meson.build8
1 files changed, 3 insertions, 5 deletions
diff --git a/src/mesa/meson.build b/src/mesa/meson.build
index 20d06aad4dd..b839fd02981 100644
--- a/src/mesa/meson.build
+++ b/src/mesa/meson.build
@@ -19,15 +19,10 @@
# SOFTWARE.
# TODO: main/tests
-# TODO: xlib_glx
-# TODO: osmesa
-# TODO: asm_offsets
subdir('program')
subdir('main')
-# program files
-# program nir files
# files shared between classic mesa and gallium mesa
files_libmesa_common = files(
'program/arbprogparse.c',
@@ -721,6 +716,9 @@ subdir('drivers/dri')
if with_osmesa == 'classic'
subdir('drivers/osmesa')
endif
+if with_glx == 'xlib'
+ subdir('drivers/x11')
+endif
if with_tests
subdir('main/tests')
endif