summaryrefslogtreecommitdiffstats
path: root/src/mesa/main/tests/meson.build
diff options
context:
space:
mode:
authorDylan Baker <[email protected]>2017-10-13 12:07:04 -0700
committerDylan Baker <[email protected]>2017-10-16 16:39:26 -0700
commit43a6e84927e3b1290f6f211f5dfb184dfe5a719e (patch)
tree28aa48fa6f1ffbe0eebe36e14ed5cc1ec7a3635f /src/mesa/main/tests/meson.build
parentc7081a3b0887e7406562e3b1d4c278f836550792 (diff)
meson: build mesa test.
v2: - add dependency on dispatch.h generator (which this test needs) Signed-off-by: Dylan Baker <[email protected]> Reviewed-by: Eric Anholt <[email protected]> (v1)
Diffstat (limited to 'src/mesa/main/tests/meson.build')
-rw-r--r--src/mesa/main/tests/meson.build43
1 files changed, 43 insertions, 0 deletions
diff --git a/src/mesa/main/tests/meson.build b/src/mesa/main/tests/meson.build
new file mode 100644
index 00000000000..2c1d8e067e8
--- /dev/null
+++ b/src/mesa/main/tests/meson.build
@@ -0,0 +1,43 @@
+# Copyright © 2017 Intel Corporation
+
+# Permission is hereby granted, free of charge, to any person obtaining a copy
+# of this software and associated documentation files (the "Software"), to deal
+# in the Software without restriction, including without limitation the rights
+# to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+# copies of the Software, and to permit persons to whom the Software is
+# furnished to do so, subject to the following conditions:
+
+# The above copyright notice and this permission notice shall be included in
+# all copies or substantial portions of the Software.
+
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+# AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+# LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+# OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+# SOFTWARE.
+
+files_main_test = files('enum_strings.cpp')
+link_main_test = []
+
+if with_shared_glapi
+ files_main_test += files(
+ 'dispatch_sanity.cpp',
+ 'mesa_formats.cpp',
+ 'mesa_extensions.cpp',
+ 'program_state_string.cpp',
+ )
+ link_main_test += libglapi
+else
+ files_main_test += files('stub.cpp')
+endif
+
+test('main-test', executable(
+ 'main_test',
+ [files_main_test, main_dispatch_h],
+ include_directories : [inc_include, inc_src, inc_mapi, inc_mesa],
+ dependencies : [idep_gtest, dep_clock, dep_dl, dep_thread],
+ link_with : [libmesa_classic, link_main_test],
+ )
+)